Breaking Tech News!

If you've just heard about something important in the tech industry, let us know.

19,608 topics in this forum

    • 0 replies
    • 213 views
    • 0 replies
    • 567 views
    • 0 replies
    • 984 views
    • 3 replies
    • 1,277 views
    • 5 replies
    • 2,535 views
    • 11 replies
    • 1,246 views
  1. Google+, look out Facebook/Myspace!

    • 6 replies
    • 5,757 views
    • 4 replies
    • 2,320 views
    • 2 replies
    • 5,022 views
    • 1 reply
    • 1,460 views
    • 1 reply
    • 1,360 views
    • 9 replies
    • 4,530 views
    • 1 reply
    • 2,325 views
    • 0 replies
    • 1,818 views
    • 1 reply
    • 2,342 views
    • 0 replies
    • 1,543 views
    • 0 replies
    • 1,541 views
    • 0 replies
    • 1,301 views
    • 0 replies
    • 1,686 views
    • 0 replies
    • 1,455 views
    • 0 replies
    • 1,574 views
    • 0 replies
    • 1,403 views
    • 0 replies
    • 1,455 views
    • 0 replies
    • 1,437 views
    • 0 replies
    • 1,493 views


  • Welcome to PCTechBytes

    Hello and welcome to PCTechBytes. We have been providing free computer repair help online since 2003. Feel free to browse the forums, but when you're ready to ask a question or comment, please be sure to register. 

  • Our picks

    • I'm new to this forum and my technical knowledge is extremely limited!

      1) Does anyone know if Microsoft are going to produce a Windows 11? I have found only conflicting information on the Internet.

      2) I have found lots of Windows 10 books on the Internet. Any recommendations for a good basic book on Windows 10?

       
      • 5 replies
    •  

       

      We pre-purchased and pre-installed the game Shadow of War on our gaming PC through Steam this week only to discover it would not launch when we clicked Play. I wanted to post our fix here in case anyone else searching the Web for clues to this needs help. 

      Tried uninstalling and reinstalling the game (all 100gigs worth). 


      Tried rolling back the nVidia graphics driver.


      Tried cursing (made me feel better but did not fix the issue). 


      Scanned and verified the game from within Steam


      Ran sfc /scannow from the command line to make sure Windows was OK.



      I ultimately realized the issue was with Visual C++ Redistributable

      I had multiple version installed. Some we very old. I removed them all and installed Visual C++ Redistributable for Visual Studio 2015 from here and that fixed it. https://www.microsoft.com/en-us/download/details.aspx?id=48145

      If anyone else had problems and found different solutions, let us know. 
      • 0 replies
  • Topics