• PCTechBytes Computer Repair Forums
      • Community Announcements
      • Introduce yourself
    • Computer Help
      • What's wrong with my computer?
      • Tips--Free-for-all!
      • Step By Step Tutorials
    • Discussion
      • Breaking Tech News!
      • Survey Central
      • Off Topic
    • Computer Security
      • Web Browsers
      • Hijack This Logs
      • Security Tips and News
    • Computer Networking
      • LAN setup
      • Network Troubleshooting
    • Operating Systems
      • Windows 10
      • Windows 7 and Windows 8 Questions
      • Mac and Linux Forum
      • Windows Legacy Operating Systems
    • Computer Hardware
      • General Computer Hardware Questions
      • Laptop and Netbook Repair
      • Build and Mod Your Computer
      • Handheld Devices
    • Major Brand Computers
    • Essential PCTechBytes
    • Gaming and Home Theater Forum
      • PC Games
      • Console Gaming
      • Home Theater


  • Welcome to PCTechBytes

    Hello and welcome to PCTechBytes. We have been providing free computer repair help online since 2003. Feel free to browse the forums, but when you're ready to ask a question or comment, please be sure to register. 

  • Our picks

    • I'm new to this forum and my technical knowledge is extremely limited!

      1) Does anyone know if Microsoft are going to produce a Windows 11? I have found only conflicting information on the Internet.

      2) I have found lots of Windows 10 books on the Internet. Any recommendations for a good basic book on Windows 10?

       
      • 5 replies
    •  

       

      We pre-purchased and pre-installed the game Shadow of War on our gaming PC through Steam this week only to discover it would not launch when we clicked Play. I wanted to post our fix here in case anyone else searching the Web for clues to this needs help. 

      Tried uninstalling and reinstalling the game (all 100gigs worth). 


      Tried rolling back the nVidia graphics driver.


      Tried cursing (made me feel better but did not fix the issue). 


      Scanned and verified the game from within Steam


      Ran sfc /scannow from the command line to make sure Windows was OK.



      I ultimately realized the issue was with Visual C++ Redistributable

      I had multiple version installed. Some we very old. I removed them all and installed Visual C++ Redistributable for Visual Studio 2015 from here and that fixed it. https://www.microsoft.com/en-us/download/details.aspx?id=48145

      If anyone else had problems and found different solutions, let us know. 
      • 0 replies
  • Topics