• Welcome to PCTechBytes

    Hello and welcome to PCTechBytes. We have been providing free computer repair help online since 2003. Feel free to browse the forums, but when you're ready to ask a question or comment, please be sure to register. 

  • 0
Neiman

Acer C720/C720p Chromebook completely dead

Question

Posted (edited)

Sorry for the long post, but here goes. So I'm repairing my broken screen on my Acer C720p Chromebook. The thing has a glass digitizer and touch screen that costs an arm and a leg to replace, so I decided to buy a screen, bezel, hinge set, and back lid for the C720 (non-touch version) and just stick that on instead. So I put in all the new parts, and I had to expose the motherboard on the bottom by opening up the bottom of the case (I had to do this to install the new hinges). I wasn't working on carpet or metal, so there is minimal opportunity for ESD damage or shorting. I wasn't wearing a static wristband, but I try to practice good static discharge habits. Everything's working fine; the peripherals, display, charger, and USB ports all work fine. So I decide to put it all back together. All of a sudden, it won't turn on. It has little indicator LEDs on the front that turn on when the laptop is running and when the charger is plugged in. Neither of the lights turn on, so I know it's not a bad connection to the new screen.  I plug it in to the AC adapter and no lights turn on. Nothing. It won't respond to any input. The laptop will automatically wake (or boot up if the system is shut down) if the lid is opened, so I close and open the lid. Nothing. I check all of the motherboard zero insertion-force flex cables and other connectors to make sure nothing is amiss. I try to start it up again. Nothing.

 

Tl;dr: Took my Acer C720p apart and it won't boot. Checked connectors and connected it to the AC adapter. None of the indicator LEDs turn on. Nothing appears to be broken or non-functional. 

 

Since it won't even indicate that it is charging, I think that it could be an issue with the power supply. So here's the question: Does anybody have some kind of laptop hardware troubleshooting checklist that I can go through? Does anyone know where I can find some in-depth documentation so that I can test the battery, power supply, and other parts of the motherboard to try and diagnose the issue? Is there some important troubleshooting steps that I have overlooked?

 

Thanks.

Edited by Neiman
Formatting was off

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Disassemble again and leave the screen assembly out and not connected.  Connect an external monitor to the VGA/DVI/HDMI port and see if it will power on.  If so you may have a short somewhere.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now




  • Our picks

    • I'm new to this forum and my technical knowledge is extremely limited!

      1) Does anyone know if Microsoft are going to produce a Windows 11? I have found only conflicting information on the Internet.

      2) I have found lots of Windows 10 books on the Internet. Any recommendations for a good basic book on Windows 10?

       
      • 5 replies
    •  

       

      We pre-purchased and pre-installed the game Shadow of War on our gaming PC through Steam this week only to discover it would not launch when we clicked Play. I wanted to post our fix here in case anyone else searching the Web for clues to this needs help. 

      Tried uninstalling and reinstalling the game (all 100gigs worth). 


      Tried rolling back the nVidia graphics driver.


      Tried cursing (made me feel better but did not fix the issue). 


      Scanned and verified the game from within Steam


      Ran sfc /scannow from the command line to make sure Windows was OK.



      I ultimately realized the issue was with Visual C++ Redistributable

      I had multiple version installed. Some we very old. I removed them all and installed Visual C++ Redistributable for Visual Studio 2015 from here and that fixed it. https://www.microsoft.com/en-us/download/details.aspx?id=48145

      If anyone else had problems and found different solutions, let us know. 
      • 0 replies
  • Popular Contributors

  • Similar Content

    • By anarchistic
      I am in need of a new laptop. Apparently, they don't even make the one I currently have (it's a Toshiba Satellite 870). The school department where I work has gone full on Chromebook so that they can use Google classroom and other tech related things. While I don't mind the Chromebooks in general, you can't download anything to them and you can't just run off a jump drive because it doesn't have an OS.
      In May, I replaced my old hard drive with a SanDisk SSD. Is it possible to turn my internal SSD into an external hard drive when the time comes for me to move up into the world of Chrome? 
       
      thank ya kindly!
    • By mattw15
      Hey guys, new here and I got a question. Just so y'all know, I suck with everything computer, and really don't completely understand what I'm doing. I'm really just trying to be able to play runescape on my chromebook. So if it sounds like I don't know what I'm talking about, it's because I don't.
      I have an Acer Chromebook 13. I got xfce using crouton, I just followed this. 
      I tried to figure out how to download firefox, but I couldn't figure it out. I attempted to figure out how to download the un-official runescape client, but I really have no idea. It's all really confusing.
      If anybody has had any experience with runescape on anything else requiring Java on a chromebook, or any inisght into how to make it happen, I would be very appreciative. And please, simple, specific instructions if possible,  I'm not good at this.
      thanks guys, -matt