• Welcome to PCTechBytes

    Hello and welcome to PCTechBytes. We have been providing free computer repair help online since 2003. Feel free to browse the forums, but when you're ready to ask a question or comment, please be sure to register. 

Sign in to follow this  
johnadam

I have 8gb ram but my system runs slowly

Recommended Posts

Posted (edited)

i have a very high configuration system as 8gb ram,1tb hard disk,2gb graphic card. but why system runs very slowly why?do i use a antivirus to protect my system? if yess then please tell me a good antivirus with a good deal such as the bitdefender discount

Edited by Dr_Bob

Share this post


Link to post
Share on other sites

Please list the parts, make and model, that make up the build.  What OS are you using?  Do you have any AV/AM currently installed?  Do you have a ton of startup programs or programs in general?

Share this post


Link to post
Share on other sites
Posted (edited)

You might have some kind of virus,malware, or spyware. Perhaps check out avast antivirus or other similiar programs.

Edited by Francco94
spelling mistake
  • Like 1

Share this post


Link to post
Share on other sites

Press Windows + r

Then type cleanmgr

tick all option

then ok

your system all junk file will deleted ,then your system running better

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  



  • Our picks

    • I'm new to this forum and my technical knowledge is extremely limited!

      1) Does anyone know if Microsoft are going to produce a Windows 11? I have found only conflicting information on the Internet.

      2) I have found lots of Windows 10 books on the Internet. Any recommendations for a good basic book on Windows 10?

       
      • 5 replies
    •  

       

      We pre-purchased and pre-installed the game Shadow of War on our gaming PC through Steam this week only to discover it would not launch when we clicked Play. I wanted to post our fix here in case anyone else searching the Web for clues to this needs help. 

      Tried uninstalling and reinstalling the game (all 100gigs worth). 


      Tried rolling back the nVidia graphics driver.


      Tried cursing (made me feel better but did not fix the issue). 


      Scanned and verified the game from within Steam


      Ran sfc /scannow from the command line to make sure Windows was OK.



      I ultimately realized the issue was with Visual C++ Redistributable

      I had multiple version installed. Some we very old. I removed them all and installed Visual C++ Redistributable for Visual Studio 2015 from here and that fixed it. https://www.microsoft.com/en-us/download/details.aspx?id=48145

      If anyone else had problems and found different solutions, let us know. 
      • 0 replies
  • Popular Contributors