• Welcome to PCTechBytes

    Hello and welcome to PCTechBytes. We have been providing free computer repair help online since 2003. Feel free to browse the forums, but when you're ready to ask a question or comment, please be sure to register. 

Sign in to follow this  
ex0LL

" Ethernet " doesn't have a valid IP configuration

Recommended Posts

Greetings.

I humbly registered to your forums seeking for help.

I am opening this thread regarding my ethernet connection: for years, I have been connecting my computer to my router via this device. The guy who sold me this, of course, told me back when I was 18 (I am now 24) that it could entirely replace an ethernet cable's performance with the benefit of space. Only 3 days ago, since I was experiencing frustrating problems related to my net, I decided to try and use a pure ethernet cable under a friend's suggestion.

I noticed, although, that my first attempt to connect the etherne cable, I couldn't really extablish an internet connection as my network icon was like this. That's why I went back to my router and tried to change the ethernet input from n°1 to n°4, and when I reached for my PC it actually fixed it. So I immediately ran a speed test to see if anything in my net performance actually improved.

As you can see from the attachment, the results were amazing, wherein before I had:
PING: 34       DOWNLOAD: 5.27Mbps     UPLOAD: 5.13Mbps

But since the cable was cutting through my room in a very unpractical and unaesthetic way, I had to unplug the cable to reposition it around my furniture and adapt it to my room. When I checked my pc, though, the same problem as before occurred. So I went back to my router and tried to change the ethernet input back to n°1, unsuccessfully. I tried any input, but nothing made a difference. I ran the troubleshooter to see if I could at least identify the problem, and the error message I received is as the title dictates:

" Ethernet " doesn't have a valid IP configuration.

I phoned an IT friend of mine to see if he could help me and he suggested me to change the ethernet cable, so I went and bought ab rand new one to replace it and see if the problem disappeared but it didn't. So I tried EACH AND EVERY possible fix I've found around the internet related to my problem, but without success.

Here's a list of the solutions I've tried without success:

  • network adapter complete uninstall, reinstall and manually update drivers previously downloaded from manufacturer's website ( Realtek PCIe FE family controller )
  • change IP and DNS from static to automatic (which I actually already setted up into automatic) in the Internet Protocol Version 4 (TCP/IPv4) Properties tab
  • change IP and DNS from automatic to static in the Internet Protocol Version 4 (TCP/IPv4) Properties tab
  • tried the following cmd commands: netsh winsock reset > netsh int ip reset > *restart pc
  • tried the following cmd commands: ipconfig /release (from which I'd receive an error) > ipconfig /flushdns > ipconfig /renew > *restart pc
  • start the PC in safe mode and try to connect to the internet: still couldn't ( which made clear to me it wasn't a driver issue anyway)
  • turn off fast startup from power settings
  • enable and disable my network adapter
  • disable firewall/antivirus
  • repeatedly launching the network troubleshooter to see if the message error changed or could eventually get fixed by itself

Until I tried to install ' Reliable Multicast Protocol ' by going here, clicking here and doing this.

The yellow warning message disappeared and I could surf the internet at its maximum performance.
I didn't have any problem until I turned off my PC and turned it back on the following day.

The same error message would pop out after running the network troubleshooter.
So after trying to uninstall and install back the protocol, as I thought it could be related since it fixed the problem for me the previous day, I tried other solutions.

What seemed to work, was going to: Control Panel > Network and Internet > Network Connections > Ethernet > Properties > Configure > Power Management > *uncheck the box near the 'Allow the computer to turn off this device to save power' option.

Just like before, I went through the all day without a single problem.
Until the following day, which is today, I had exactly the same yellow warning triangle with the same error message: ' Ethernet ' doesn't have a valid IP configuration.
That's why I desperately once more went to the same option tab that seemed to fix my problem the day before and checking back the box, then restarting the PC then unchecking it once more. And after all of this, I tried to run the troubleshooter and, surprise, this time it fixed it by itself.

For now, I am using once more my connection through my internet cable without a problem and at the fullest, but to prevent this from happening tomorrow when I come back from work (which is going to frustrate me a lot), I am asking for help.

I sincerely thank you all in advance and I hope you have a great day :-)
 

my connection.PNG

Share this post


Link to post
Share on other sites

Sounds like you have a lot going on there. It's not uncommon for an adapter to lost the connection when something changes. I always prefer to enable DHCP in the router and keep all of the computers I have set to automatically get the IP address. 

 

I would power everything off--including the router / modem and then power up the modem first--let it sit for a minute or two, and then power up the computer. If everything is working properly, the router will see the computer come online and provide it with the gateway and IP address it needs to function. 

Also, check the DNS setting in the router. You can change them to something like OpenVPN--which is what I use. Or googles DNS, which is also good. 

Share this post


Link to post
Share on other sites
Posted (edited)
33 minutes ago, Dave@Bytes said:

Also, check the DNS setting in the router. You can change them to something like OpenVPN--which is what I use. Or googles DNS, which is also good.


So I should change DNS from automatic to static?
But won't allow for my IP to be selected automatically, right?

Edited by ex0LL

Share this post


Link to post
Share on other sites

If you are going to use a third party DNS, yes, change it to static. Change it to static. You can find OpenDNS' DNS address on their website. I recommend creating a free account with them, too, as you can setup parental controls, etc, in the control panel. 

Share this post


Link to post
Share on other sites
38 minutes ago, Dave@Bytes said:

If you are going to use a third party DNS, yes, change it to static. Change it to static. You can find OpenDNS' DNS address on their website. I recommend creating a free account with them, too, as you can setup parental controls, etc, in the control panel. 


Isn't there a way for me to setup a static DNS using one at disposal from my OS?
I'd prefer not to use third party programs.

Share this post


Link to post
Share on other sites

You're either going to use your ISPs or one from another provider. It's not actually a program, just a service. If you want to stick with your Internet provider's DNS just keep everything at dynamic. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  



  • Our picks

    • I'm new to this forum and my technical knowledge is extremely limited!

      1) Does anyone know if Microsoft are going to produce a Windows 11? I have found only conflicting information on the Internet.

      2) I have found lots of Windows 10 books on the Internet. Any recommendations for a good basic book on Windows 10?

       
      • 5 replies
    •  

       

      We pre-purchased and pre-installed the game Shadow of War on our gaming PC through Steam this week only to discover it would not launch when we clicked Play. I wanted to post our fix here in case anyone else searching the Web for clues to this needs help. 

      Tried uninstalling and reinstalling the game (all 100gigs worth). 


      Tried rolling back the nVidia graphics driver.


      Tried cursing (made me feel better but did not fix the issue). 


      Scanned and verified the game from within Steam


      Ran sfc /scannow from the command line to make sure Windows was OK.



      I ultimately realized the issue was with Visual C++ Redistributable

      I had multiple version installed. Some we very old. I removed them all and installed Visual C++ Redistributable for Visual Studio 2015 from here and that fixed it. https://www.microsoft.com/en-us/download/details.aspx?id=48145

      If anyone else had problems and found different solutions, let us know. 
      • 0 replies
  • Popular Contributors