• Welcome to PCTechBytes

    Hello and welcome to PCTechBytes. We have been providing free computer repair help online since 2003. Feel free to browse the forums, but when you're ready to ask a question or comment, please be sure to register. 

  • 0
Sign in to follow this  

Question

My IMac lately has been having problems, when I boot it up the screen does the normal white flash all Macs do, but then the rest of it is just a black screen non-lit. And that's the farthest it'll go. I can't access CMD or boot in safe-mode. The only problem I can think of is a corrupted harddrive but I can't access the inside of it currently. (Need Suction Cups) my temps are bad so I wouldn't be surprised if I have anything fried, my CPU has been at 87 and 93 temps before, and yes I do game with a Mac it was a gift when I was 13 back in 2011. I'd like to know if anyone else knows the problem before I spend more money on a dead machine.

IMac All-in-one. Hardware if needed*

Intel i52500s

AND Raddeon 6770S HD

8gb of ram

Harddrive I have no clue.

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Yea the first thing you should have done was take it apart when it was getting hot and fix that issue with new thermal paste and a cleaning.  It is entirely possible that the heat fried something.  You can try running the diagnostics on your HDD and RAM here: https://support.apple.com/en-us/HT201257

 

Without knowing if you have a bad HDD or not we cant really go much further with the diagnostics.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  



  • Our picks

    • I'm new to this forum and my technical knowledge is extremely limited!

      1) Does anyone know if Microsoft are going to produce a Windows 11? I have found only conflicting information on the Internet.

      2) I have found lots of Windows 10 books on the Internet. Any recommendations for a good basic book on Windows 10?

       
      • 5 replies
    •  

       

      We pre-purchased and pre-installed the game Shadow of War on our gaming PC through Steam this week only to discover it would not launch when we clicked Play. I wanted to post our fix here in case anyone else searching the Web for clues to this needs help. 

      Tried uninstalling and reinstalling the game (all 100gigs worth). 


      Tried rolling back the nVidia graphics driver.


      Tried cursing (made me feel better but did not fix the issue). 


      Scanned and verified the game from within Steam


      Ran sfc /scannow from the command line to make sure Windows was OK.



      I ultimately realized the issue was with Visual C++ Redistributable

      I had multiple version installed. Some we very old. I removed them all and installed Visual C++ Redistributable for Visual Studio 2015 from here and that fixed it. https://www.microsoft.com/en-us/download/details.aspx?id=48145

      If anyone else had problems and found different solutions, let us know. 
      • 0 replies
  • Popular Contributors

  • Similar Content

    • By Nightfall
      Hello, I am trying to restore my Windows 98 Gateway so that I can enjoy some old programs once again. It powers on but gives me this error message upon trying to boot to desktop. What is this error and how can I fix it? 

    • By Arthur_Barker
      Hi, 
      My Desktop has recently been updated, and it now won't start up again. I turn it on and it just gets stuck on that spinning wheel. I tried that rebooting it three times to get the start up repair but it never appears. Any idea on how to fix this?
       
      Arthur 
    • By HeyImBora
      Hey guys. Im bora.
      So, I'll explain my story.
      Yesterday night I went to bed with my iMac installing a 62.7 gb game. 10 hours later when I woke up I got a weird message my finder kept shutting off, I restarted my computer and the same thing happened. I wanted to restart my Imac again and it doesnt go past the loading screen with the apple logo and the loading bar at halfway full.
       
      All these guides on the internet are way too hard for me and its my nephews iMac I am borrowing and Id rather fix it myself then going with it to the store. Its an older Imac, probably from 2010-2011.
      Thank you so much if u want to help me Im really feeling bad rn.
       
      When I press cmd - R it goes way further but when the loading bar is about to be full it goes to macOS helpprograms.
    • By monadowhirl
      So a couple days ago I dual installed linux ubuntu alongside with my preexisting windows 10. i used it for a week and then decided i wanted to shorten my partition space for ubuntu. In doing so, i deleted a couple of other windows partitions by accident( i believe i deleted the msr and recovery disks) and when i restarted windows 10 an error screen telling me i need to restart would come up (it looked like this ~ https://images.scdn8.secure.raxcdn.com/wp-content/uploads/2017/06/img_594b73734961c.jpg). Every time it would restart the same error would come back.
       
      This is what I tried:
      system restore and reset
      startup repair tool
      testdisk on ubuntu (though I haven't exhausted all the options it gave me)
       
      I used testdisk to revive on of my drives (i dont think it was the  msr drive) and when i restarted the computer I got the attached recovery error. Pressing enter did nothing and pressing f8 also did nothing. So now I'm downloading windows 10 media on a usb to recover it and ill see if that works. Nevertheless, is there anything I should do? I still have an ubuntu usb so if that could help fix this problem then that'd be great.

    • By Kim Taehyung
      Hello everyone,
      yesterday my girlfriend tried to reset our laptop because she was having some difficulties with Windows 10. Now whenever I turn it on "An operating system wasn't found. Try disconnecting any drives that don't contain an operating system." comes up. I've tried to restart it just like it says at the bottom but it doesn't do much. Restarts the laptop but it keeps coming back to that page. I have no clue how to deal with this. Also, Windows 10 was an update of our old system and I don't have the CD for the old one anymore.
       
      Can anyone help me? Would be glad.